Temperature Dependence of Conductivity in Graphene
Final Project in the Computational Physics course
Fall Semester 2012-3
Tzipora Izraeli

1 About the Project

In a perfect crystal the electrons move as if they are free particles with effective mass \( m^* \) moving in a vacuum. Otherwise, we say that the electrons undergo collisions and are scattered. It is due to these collisions that the material is resistant to the flow of electric current. There are many scattering mechanisms which can affect the electrons, the major ones being defects in the crystal, phonons, and impurities.

The mechanism studied in this project is screened Coulomb scattering by charged impurities from the environment. The numeric calculation, following the paper by Hwang and Das Sarma[1], is based on the assumption that this is the dominant contribution to the scattering. The Ohmic resistivity of the graphene electrons is calculated by the finite-temperature Drude-Boltzmann theory. The screening effect of the impurities is treated in the random phase approximation.

After a short description of graphene and the experimental results of the temperature dependence of conductivity, there is an extensive section on the theory, and a short explanation about numerical solutions. The simulation code is available for download, and is followed by a discussion of the results.

2 Graphene

General description and history

Graphene is a sheet of carbon, one atom thick, arranged in a honeycomb lattice. Graphite, the common allotrope of carbon, consists of a stack of many graphene layers held together by weak (van der Waals) interactions. Most pencils have a graphite core. When pressure is applied, some of the weak bonds break, and the layers are separated. (Graphite was actually named after this use, from the Greek γράφω - to write.) The distance between the layers is 0.336 nm, so 1mm of graphite is made of approximately 3 million sheets, and even a thin smudge of pencil line is composed of many layers.

(The picture adapted from The Nobel Prize in Physics 2010 press release.)

The physical properties of graphene were studied theoretically long before a single layer of graphene was isolated and available for measurements. In 1947 Philip Wallace published a detailed calculation of the band structure of graphene[2]. Fifty seven years later, in 2004, Andre Geim and Konstantin Novoselov discovered how to prepare films of few layer carbon crystals by micro-mechanical cleavage of graphite[3]. This method of mechanical exfoliation is also called “the Scotch tape method”, after the adhesive tape with which the repeated peeling is done. By 2005 it was established that crystal flakes produced in this manner are actually single layer graphene[4]. In 2010, Novoselov and Geim were awarded the Nobel Prize in Physics “for groundbreaking experiments regarding the two-dimensional material graphene”[5].

This truly two dimensional structure exhibits unique properties that have attracted much attention in recent years. Graphene enables experimental testing of a wide range of previously inaccessible phenomena, thus providing insights into basic physics. The remarkably high electric conductivity and mechanical strength
of graphene hold promise for its use in a wide range of applications and suggest that it will play a central role in the next generation of electronics.

3 Conductivity and Temperature Dependance

Electrical conductivity, represented by the letter $\sigma$, is a measure of a material’s ability to conduct an electric current. Resistivity, represented by $\rho$, is the inverse quantity, $\rho = \frac{1}{\sigma}$, and it quantifies how strongly the material opposes the flow of the current. In some contexts, such as experiments, it is more convenient to consider the resistivity, while in others, such as the theory presented in this project, it is useful to consider the conductivity. These values are temperature dependent. In metals the resistivity decreases as temperature is reduced, $\frac{\partial \rho}{\partial T} > 0$. In other materials resistivity increases as temperature is reduced, $\frac{\partial \rho}{\partial T} < 0$.

The following graph from the article by Bolotin et al in 2008 [6] shows the measured resistivity for graphene at different temperatures, as a function of the carrier density.

At low carrier density ($n < n^*$), the experimentally observed temperature dependance of conductivity in graphene is pronouncedly non metallic (the resistivity increases as temperature is reduced), while above the critical density $n^*$ it is metallic.

This peculiar behavior aroused much interest, and was investigated further, so far it is not completely understood. Here is a graph of resistance varies with temperature for different gate voltages (which is equivalent to density) from article [7].
4 Theoretical Approach

4.1 Band theory

4.1.1 Two Dimensional Electron Gas (2DEG)

The dispersion relation of an electronic system is the mathematical relation between the energy and momentum of the states the electron may occupy. Here is an example of a dispersion relation typical of semiconductors \[8\] :

\[
\epsilon(k) = \epsilon_v + \frac{\hbar^2}{2m} k^2
\]

The available energy states in the semiconductor are continuous, and form bands (unlike the states of a single atom which are discrete). The lowest band is called the valance band and similarly to valence electrons in an individual atom it is mostly occupied. The higher band is called the conduction band, because current can flow only when it is occupied.

In the region where most of the charge carriers are found, close to the energy gap, the bands can be approximated in the quadratic form. For electrons \(\epsilon(k) = \epsilon_v + \frac{\hbar^2}{2m} k^2\) and for holes \(\epsilon(k) = \epsilon_v - \frac{\hbar^2}{2m} k^2\). This spectrum resembles that of free electron Hamiltonian \(H = -\frac{\hbar^2}{2m} \nabla^2\), with plane waves \(\psi_k(r) = \frac{1}{\sqrt{A}} \exp(ik \cdot r)\) where \(\frac{1}{\sqrt{A}}\) is a normalization factor for the size of the system, \(A\). In this approximation, the electrons do not interact with each other, but do fill energy states according to the Pauli exclusion principle (no two electrons in the same state). A system like this is called an electron gas. If it is confined in one of the spatial directions, limiting the motion of the electrons to the other two, it is called a two dimensional electron gas - 2DEG.

4.1.2 Graphene

The tight binding model is an approach used in solid state physics to calculate states and energies of a periodic system. It assumes that the state of the system is a superposition of localized states with small overlap which obey the single site equation. In a crystal we have a lattice of atoms, and we are interested in the energy states that each electron can occupy. The tight binding assumption is that each electron is “tied” to its respective atom, almost the same way it would be if there was just the one atom, with a small amount of “spreading” due to the neighboring atoms. The shared “molecular state” of an electron in the crystal is the sum of all these single electron states.

Calculations for the two dimensional hexagonal lattice of graphene \[2\] yield a “egg carton” shaped dispersion relation between the energy and the momentum \((k)\).

In graphene, unlike most materials, the two bands meet, which leads to unique behavior \[9, 10\], some of which we will see in this project. The point where the conduction and valence bands touch is called the \textbf{Dirac point}. The bands meet at six points, but due to the symmetry only two of them are distinct (\(K\) and \(K'\)), and the other four are equivalent to them. This duplicity of Dirac points leads to the “valley degeneracy” \(g_v = 2\).
4.1.3 Dirac-Weyl Hamiltonian and solutions

The Hamiltonian of graphene near the Dirac points can be approximated as \( H = \hbar v_F (\sigma_x k_x + \sigma_y k_y) \), where:

- \( \hbar \) is the reduced Plank constant, \( \hbar = 6.582 \times 10^{-16} eV \cdot s \).
- \( v_F \) is 2D Fermi velocity of graphene, measured to be \( v_F \approx 10^8 \text{ cm/sec} \) (which is \( 1/300 \) the speed of light).
- \( \sigma_x, \sigma_y \) are the Pauli spinors: \( \sigma_x = \begin{pmatrix} 0 & 1 \\ 1 & 0 \end{pmatrix}, \sigma_y = i \begin{pmatrix} 0 & -1 \\ 1 & 0 \end{pmatrix} \).
- \( k \) is the momentum relative to the Dirac points, \( k = (k_x, k_y) \).
- \( \theta_k \) is the polar angle of \( k \), \( \theta_k = \tan^{-1} \left( \frac{k_y}{k_x} \right) \).

The solutions are plane wave eigenstates \( \psi_{sk}(r) = \frac{1}{\sqrt{A}} \exp(ik \cdot r) F_{sk} \) where:

- \( s \) stands for conduction \( (s = +1) \) or valence \( (s = -1) \) band.
- \( F_{sk} \) is a term resulting from the fact that there are two sub-lattices ("pseudo-spin"), and does not appear in 2DEG. \( F_{sk} = \frac{1}{\sqrt{2}} \begin{pmatrix} e^{-i\theta_k} \\ s \end{pmatrix} \).
- \( \frac{1}{\sqrt{A}} \) is a normalization factor for the size of the system, \( A \).

The corresponding energies are \( \epsilon_{sk} = s \hbar v_F |k| \)

So we have a linear dispersion relation, like photons. (as opposed to the parabolic one of 2DEG)

The group velocity is defined as \( v = \frac{1}{\hbar} \frac{\partial E}{\partial k} \), so \( v = v_F \)

The effective mass is defined as \( m^* = \frac{\hbar^2}{2 \pi^2} \frac{\partial^2 E}{\partial k^2} \) so \( m^* = 0 \).

We see that the electrons in graphene have ultra-relativistic characteristics.

4.1.4 Electronic Quantities

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Symbol</th>
<th>Meaning</th>
<th>Parabolic 2D system</th>
<th>Graphene</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dispersion relation</td>
<td>( E(k), \epsilon(k) )</td>
<td>Relation between the energy and momentum</td>
<td>( \frac{\hbar^2}{2m} k^2 )</td>
<td>( \hbar v_F</td>
</tr>
<tr>
<td>Fermi wave vector</td>
<td>( k_F )</td>
<td>The radius in k-space for which the non interacting states are filled, that is, ( n = \frac{\sqrt{\pi} k_F^2}{(2\pi)^3} ) per unit area of degeneracy</td>
<td>( \sqrt{2\pi n} )</td>
<td>( \sqrt{\pi n} (\ast) )</td>
</tr>
<tr>
<td>Fermi Energy</td>
<td>( E_F )</td>
<td>The maximal occupied level of energy at ( T=0 ): ( E(k_F) )</td>
<td>( \frac{n\pi k_F^2}{m} )</td>
<td>( \hbar v_F \sqrt{\pi n} )</td>
</tr>
<tr>
<td>Fermi Velocity</td>
<td>( v_F )</td>
<td>The velocity associated with the kinetic energy equal to ( E_F )</td>
<td>( \frac{\hbar}{m} k_F )</td>
<td>( v_F )</td>
</tr>
<tr>
<td>Density of States (DOS)</td>
<td>( D(E) )</td>
<td>Number of states available at each energy level: ( \frac{\partial N}{\partial E} )</td>
<td>( \frac{m}{\pi k_F^2} )</td>
<td>( \frac{e^2}{\pi \hbar v_F E} )</td>
</tr>
<tr>
<td>DOS at ( E_F )</td>
<td>( D_0 )</td>
<td>The number of states available at ( E_F ): ( D(E_F) )</td>
<td>( \frac{m}{\pi k_F^2} )</td>
<td>( \frac{\sqrt{\pi}}{\sqrt{\pi \hbar v_F}} )</td>
</tr>
</tbody>
</table>
The Fermi wave vector for graphene is divided by an additional factor $g_v = 2$ due to the valley degeneracy. Both systems have a spin degeneracy $g_s = 2$.

In addition we denote the charge carrier density $n$, and the Fermi temperature $T_F \equiv \frac{E_F}{k_B}$.

### 4.2 Fermi Energy and Chemical Potential

The net charge is the difference between the number of electrons and the number of holes. In terms of density, this can be expressed as:

$$n = n_e - n_h = \int_0^\infty \frac{dD}{d\epsilon} f(\epsilon) - \int_0^\infty \frac{dD}{d\epsilon} (1 - f(\epsilon)).$$

(The probability for a hole state to be occupied is $1 - f(\epsilon)$, complimentary to the probability of the electron state of the same energy being occupied.)

For graphene, substituting $n = \frac{E_F^2}{\pi \hbar^2 v_F^2}$ in the left side of the equation, and the expressions for $D(\epsilon)$, $f(\epsilon)$ in the right hand side, and using the definition $T_F \equiv E_F/k_B$, we get an implicit function for $\mu$:

$$\frac{1}{2} \left( \frac{E_F}{T} \right)^2 = F_1(\beta \mu) - F_1(-\beta \mu)$$

with $\beta \equiv \frac{1}{k_B T}$ and $F_n(x) = \int_0^\infty \frac{e^{\alpha t}}{1 + \exp(bx)} dt$.

For a 2DEG the solution for $\mu$ is explicit: $\mu = k_B T \ln \left( e^{n\pi^2/\hbar^2/2m_k} T - 1 \right)$.

#### 4.2.1 Boltzmann Transport Theory

Assume a homogeneous 2D system with carrier density $n$, which is induced by the external gate voltage $V_g$ (either electrons or holes). If a weak external field, such that only a small displacement of the distribution function from thermal equilibrium is caused, the distribution function my be written as $f_{sk} = f(\epsilon_{sk}) + g_{sk}$ where $f(\epsilon_{sk}) = (1 + \exp[(\epsilon_{sk} - \mu)/k_B T])^{-1}$ is the equilibrium Fermi distribution function, and $g_{sk}$ is proportional to the applied electric field $E$, which is assumed to be spatially uniform and steady state.

Boltzmann transport equation (Linear response) states that

$$\left( \frac{df_{sk}}{dt} \right)_c = \frac{df(\epsilon_{sk})}{d\epsilon} - eE \cdot \text{vs}_{sk} \frac{df}{d\epsilon} = -\int \frac{d^2k}{(2\pi)^2} (g_{sk} - g_{sk'}) W_{sk,sk'}.$$  

Where $\text{vs}_{sk} = \frac{d\epsilon_{sk}}{dk} = s v_F \frac{k}{|k|}$ is the velocity of the carrier. $W_{sk,sk'}$ the quantum mechanical probability of scattering from $sk$ to $sk'$.

Within the Born approximation $W_{sk,sk'} = \frac{2\pi}{h} n_s |\langle V_{sk,sk'} \rangle|^2 \delta (\epsilon_{sk} - \epsilon_{sk'})$ where $\langle V_{sk,sk'} \rangle$ is the matrix element for the scattering potential [in this case associated with impurity disorder in the graphene environment], and $n_s$ is the number of impurities per unit area.

According to the usual approximation scheme, we do ensemble averaging over random uncorrelated impurities. Furthermore, we focus on elastic impurity scattering [inter-band processes $(s \neq s')$ are not permitted].

Under these assumption, the scattering time can be isolated from $g_{sk} = -\frac{\epsilon(\epsilon_{sk})}{h} eE \cdot \text{vs}_{sk} \frac{df}{d\epsilon}$, and this is called the relaxation time approximation $\frac{1}{\tau(\epsilon_{sk})} = 2\pi \hbar \int \frac{d^2k'}{(2\pi)^2} |\langle V_{sk,sk'} \rangle|^2 (1 - \cos \theta_{kk'}) \delta (\epsilon_{sk} - \epsilon_{sk'})$. $\theta_{kk'}$ is the scattering angle between the in and out wave vectors $k$ and $k'$.

Substituting the current density $j = q \int \frac{d^2k}{(2\pi)^2} e \text{vs}_{sk} f_{sk}$ into the expression $j = \sigma E$ we can find an expression for the conductivity, sigma. By averaging over the energy

$$\sigma = \frac{q^2 v_F^2}{2} \int_0^\infty \frac{dD}{d\epsilon} \tau(\epsilon) \left( -\frac{df}{d\epsilon} \right)$$

(Only electrons in partially filled bands contribute to the conduction, in our case these are the electrons with positive energies.)

In the limiting case $T = 0$, $f(\epsilon)$ is a step function. Recalling that $E_F \equiv \mu(T = 0)$, the usual conductivity formula is recovered $\sigma = \frac{q^2 v_F^2}{2} D(E_F) \tau(E_F)$.

We get

$$\sigma = \frac{q^2 v_F^2}{2} \int D(\epsilon) \tau(\epsilon) \left( -\frac{df}{d\epsilon} \right)$$

The dependance on temperature enters the equation from two independent sources:

1. the energy averaging (of the integral) and
2. the dielectric function which effects the screening and thus effects $\tau$, $\epsilon(q, T) \rightarrow \tau(q, T, \epsilon)$ even if $\tau$ does not’ depend explicitly on $T$, if it has some dependance on $\epsilon$, the energy averaging will introduce temp dependance

we are interested in understanding the combined contribution.

#### 4.2.2 Random Impurity Scattering

The matrix element of scattering potential for randomly screened impurity charge centers in graphene is
\[ |\langle V_{sk,sk'} \rangle|^2 = \left| \frac{v(q)}{\epsilon(q)} \right|^2 \frac{1+\cos \theta}{2}, \]

where:

\[ q = |k - k'| \quad \theta \equiv \theta_{kk'}. \]

\[ v(q) = \frac{2\pi e^2}{\kappa q} \] is the Fourier transform of the 2D Coulomb potential in an effective background lattice dielectric constant \( \kappa \). The term \( \frac{1+\cos \theta}{2} \) comes from the sub lattice symmetry (overlap of wave functions) \[11\].

The expression for the relaxation time is:

\[ \frac{1}{\tau_{sk}(\epsilon)} = \frac{2\pi}{\hbar} \int \frac{d^2k'}{(2\pi)^2} |\langle V_{sk,sk'} \rangle|^2 \left[ 1 - \cos \theta_{kk'} \right] \delta(\epsilon_{sk} - \epsilon_{sk'}) \]

Let us examine the scattering angle, \( \theta \), terms:

It always contain a \((1 - \cos \theta)\) term that suppresses small angle scattering, and is good for large angle scattering, in particular backward scattering of \(+k_F\) to \(-k_F\). In graphene, there is an additional term \((1 + \cos \theta)\) from the overlap of wave functions, which suppresses large angle scattering, so the main contribution in graphene is at \( \theta = \frac{\pi}{2} \) - “right-angle” scattering.

### 4.2.3 The Dielectric (Screening) Function

The Dielectric screening function can be written as:

\[ \epsilon(q,T) = \frac{\epsilon(q)}{\epsilon(q,T)} = 1 + v_c(q,T) \Pi(q,T) \]

where \( v_c(q) \) is the Coulomb interaction, and \( \Pi(q,T) \) is the static polarizability function. \( \Pi(q,T) \) can be calculated from the bare bubble diagram \[12\] as

\[ \Pi(q,T) = -\frac{q}{\hbar} \sum_{k > s'} \frac{f_{sk} - f_{sk'}}{\epsilon_{sk} - \epsilon_{sk'}} F_{ss'}(q,k,k') \]

After summation over \( ss' \), rewriting as a of intraband in inter-band polarizability:

\[ \Pi(q,T) = \Pi^+(q,T) + \Pi^-(q,T) \]

and preforming angular integration over \( \phi \), the angle between \( k \) and \( q \): \( \cos \theta_{kk'} = \frac{k + q \cos \phi}{|k + q|} \), and then normalizing by the density of states at Fermi level \( D_0 \equiv \frac{2k_F \pi^2 h^2}{3e^2_F} \), dimensionless quantities are reached.

\begin{align*}
\Pi^+(q,T) &= \frac{\mu}{E_F} + \frac{T}{T_F} \ln (1 + e^{-\beta \mu}) - \frac{1}{k_F} \int_0^{q/2} dk \frac{\sqrt{1-(2k/q)^2}}{1 + \exp \left[ \beta (\epsilon_k - \mu) \right]} \\
\Pi^-(q,T) &= \frac{\pi q}{8 k_F} + \frac{T}{T_F} \ln (1 + e^{-\beta \mu}) - \frac{1}{k_F} \int_0^{q/2} dk \frac{\sqrt{1-(2k/q)^2}}{1 + \exp \left[ \beta (\epsilon_k + \mu) \right]}
\end{align*}
where $\tilde{\Pi}(q, T) = \tilde{\Pi}^+(q, T) + \tilde{\Pi}^-(q, T)$

At $T=0$ there are exact solutions.

$$\tilde{\Pi}^+(q, T) = \begin{cases} \frac{\pi q}{8k_F} & q \leq 2k_F \\ \frac{1}{2}\sqrt{1 - \frac{4k_F^2}{q^2}} - \frac{q}{4k_F} \sin^{-1} \frac{2k_F}{q} & q > 2k_F \end{cases}$$

$$\tilde{\Pi}^-(q, T) = \frac{\pi q}{8k_F}$$

It is convenient to define the screening constant or screening wave vector $q_s$.

$$U(q) = \frac{\epsilon(q)}{\epsilon(q)} = \frac{2\pi e^2}{\kappa q [1 + v(\tilde{\Pi}(q))] = \frac{2\pi e^2}{\kappa (q + q_s)}$$

5 Numerical Solution

In this project two types of numerical calculations are used. Here is a short description of them. For more information see for example the book by S. J. KOONIN, “Computational Physics”[13].

5.1 Finding Roots - Newton–Raphson method

This is a method to find $x$ for which $f(x) = 0$. Obviously this is useful for the common problem of finding when two functions $g$ and $h$ intersect (i.e. when $g(x) = h(x)$), because we can define $f(x) = g(x) - h(x)$.

Starting from an initial guess $x_0$ for the value of the root, the approximation is improved to $x_1 = x_0 - \frac{f(x_0)}{f'(x_0)}$.

Higher accuracy is achieved by repetition of the process $x_{n+1} = x_n - \frac{f(x_n)}{f'(x_n)}$. This is simply an algebraic result from the approximation of the derivative $f'(x_n) \approx \frac{\Delta y}{\Delta x} = \frac{f(x_n) - 0}{x_n - x_{n+1}}$.

5.2 Calculating Definite Integrals - Numerical quadrature

The integral of $f$ between $a$ and $b$, $\int_a^b f(x) \, dx$ is calculated as the sum of a large number of integrals over the small interval $2h$, where $h = \frac{b-a}{N}$: $\int_a^b f(x) \, dx = \int_a^{a+2h} f(x) \, dx + \int_{a+2h}^{a+4h} f(x) \, dx + \cdots + \int_{b-2h}^b f(x) \, dx$.

The integral over the small interval is evaluated by interpolation of $f$ as a polynomial.

1. Midpoint rule or rectangle rule:

$f$ is assumed to be constant (polynomial of degree 0),

$$\int_a^b f(x) \, dx = h \cdot f(0)$$

↓better
2. Trapezoidal rule:

\[ f(x) \text{ is assumed to be linear (polynomial of degree 1).} \]
\[ \int_{-h}^{h} f(x) \, dx = \frac{h}{2} \left( f(-h) + 2f(0) + f(h) \right) + O(h^3) \]

The integral over the combined interval is
\[ \int_{a}^{b} f(x) \, dx \approx \frac{h}{2} \left( f(a) + 2 \cdot \sum_{k=1}^{N-1} f(a + k \cdot h) + f(b) \right) \]
\[ \downarrow \text{better.} \]

3. Simpson’s rule:

\[ f(x) \text{ is assumed to be quadratic (polynomial of degree 2).} \]
\[ \int_{-h}^{h} f(x) \, dx = \frac{h}{3} \left( f(-h) + 4f(0) + f(h) \right) + O(h^5) \]

The integral over the combined interval is
\[ \int_{a}^{b} f(x) \, dx = \frac{h}{3} \left( f(a) + 4f(a + h) + 2f(a + 2h) + 4f(a + 3h) + \cdots + 4f(b - h) + f(b) \right) \]
\[ \downarrow \text{better} \]

polynomial of degree 3 etc.

6 Instructions and Download

Since the Simulation contains many calculations, the running time is long. There are two options: to run the complete simulation or to view results from data I produced.

To run the complete simulation:

The parameters set here are such that the simulation will run relatively fast, at the expense of lower accuracy. Changing the parameters might cause the simulation calculation time to be longer.

1. Download

Download the following files into the directory you wish to work in. (If necessary create new folder).

If the files do not download automatically when selected, use the right click option menu → “Save Link as...”.

GTC.m

If you have Mathematica: calc_m.m.nb

If you do not have Mathematica: t.txt, m.txt

2. Mathematica Section

This part is the calculation of the chemical potential \( \mu \) from the self consistent equation based on Newton-Raphson method.

The output from this notebook is two text files of the same length, one of the temperatures, and the other of the values of \( \mu \) in the corresponding places.
(a) Run Mathematica
Windows: click Mathematica icon or Start → All Programs → Wolfram Mathematica
Linux: mathematica &

(b) Open the notebook calc_mun.nb
(Ctrl+o) or (File → Open → /calc_mun.nb)

(c) You may change the values set for \( T_{\text{min}} \), \( T_{\text{max}} \), \( \delta T \) - the normalized temperatures which will be used in the simulation.
The default setting is \( T_{\text{min}} = 0.01 \), \( T_{\text{max}} = 1.5 \), \( \delta T = 0.01 \).

(d) Evaluate the notebook
(Ctrl+a) → (Shift+Enter) or (Evaluation → Evaluate notebook)

3. MATLAB Section

(a) Run MATLAB
Windows: click MATLAB icon or Start → All Programs → MATLAB
Linux: matlab &

(b) Change directory
\( cd(’\text{path to your folder - for example: } \\
C://\text{Documents/Project }’) \) or (File → Set Path → Add Folder → your folder)

(c) If you wish to change the parameters:
i. Open the file: open(’GTC’) or (File → Open→/GTC.m)
ii. Make your changes.
iii. Save: (Ctrl+s) or (File → Save As)

(d) Run the program: Type GTC in the Command window.
This will preform the calculation of the conductivity, and present graphs of intermediate values.

To view results from data file:

1. Download
Download the following files into the directory you wish to work in. (If necessary create new folder).
If the files do not download automatically when selected, use the right click option menu →“Save Link as…”.
GTC_view.m, GTC_data.mat

2. Run MATLAB
Windows: click MATLAB icon or Start → All Programs → MATLAB
Linux: matlab &

3. Change directory
\( cd(’\text{path to your folder - for example: } \\
C://\text{Documents/Project }’) \) or (File → Set Path → Add Folder → your folder)

4. Open the file: open(’GTC’) or (File → Open→/GTC_view.m)

5. Run the script: (F5) or (Cell → Evaluate Entire File)
This will plot graphs of the different values that were calculated.

7 Results and Discussion

7.1 Chemical Potential calculation

In the theoretical section we saw that the chemical potential \( \mu \) of graphene is given by the implicit function:
\[
\frac{1}{2} \left( \frac{\mu}{k_B T} \right)^2 = F_1(\beta \mu) - F_1(-\beta \mu) \quad \text{with} \quad \beta \equiv \frac{1}{k_B T}
\]
and \( F_n(x) = \int_0^\infty \frac{e^t}{1+e^{x+t}} \).

For \( n = 1 \), \( F_1 \) equals the poly-logarithm function of \(-e^x\): \( F_1(x) = -\text{Li}_2(-e^x) \). The poly logarithms are characterized by \( \frac{d}{dx} \text{Li}_n(x) = \frac{n}{x} \text{Li}_{n-1}(x) \), in conjunction with \( \text{Li}_n(0) = 0 \) and \( \text{Li}_1(x) = -\ln(1-x) \). These functions are implemented in Mathematica and were used to solve for \( \mu \).
$F_1(x)$ limiting forms are $F_1(x) \approx \frac{x^2}{12} + x \ln 2 + x^2$ for $|x| \ll 1$ and $F_1(x) \approx \left[ \frac{x^2}{12} + \frac{x^2}{4} \right] \theta(x) + x \ln \left( 1 + e^{-|x|} \right)$ for $|x| \gg 1$.

Therefore $\mu(T) \approx E_F \left[ 1 - \frac{x^2}{6} \left( \frac{T}{T_F} \right)^2 \right]$ for $T/T_F \ll 1$

$\mu(T) \approx \frac{E_F T_F}{2}$ for $T/T_F \gg 1$.

So we see that the limiting forms fit the graph fairly well. The low temperature limit approximation is valid for $T/T_F \ll 0.35$ and the high temperature limit approximation is accurate for $T/T_F \gtrsim 0.9$.

For comparison, here is the graph of $\mu = k_B T \ln \left( e^{n \pi \hbar^2/mk_B T} - 1 \right)$ for 2DEG:
The chemical potential is almost constant for small $T$ in 2DEG, whereas in graphene it decreases rapidly in that region.

In 3D materials the chemical potential is approximately constant for a large range around room temperature.

### 7.2 Fermi Distribution and Derivative

Fermi distribution function

$$f = \frac{1}{\exp \left( \frac{\epsilon_s k}{k_B T} \right) + 1}$$

behaves differently for different temperatures $T$. Since the chemical potential $\mu$ varies strongly with $T$, it is instructive to examine the distribution function, and its derivative.

$$\frac{\partial f}{\partial \epsilon} = \frac{1}{k_B T} \exp \left( \frac{\epsilon_s k}{k_B T} \right) \left( 1 + \exp \left( \frac{\epsilon_s k}{k_B T} \right) \right)^{-2} \times \left( f(\epsilon) \right)^2$$

We see that as $T$ approaches zero, $f$ is a sharper step function, and correspondingly, there is a high peak in the derivative. For higher temperatures the function is more spread out - around the order of $T$. We see in the graphs that the chemical potential is the value for which $f = \frac{1}{2}$. As $T$ grows larger, $\mu$ is lowered.

In graphene this shift is much more pronounced than in a 2DEG.

### 7.3 Polarizability

I calculated numerically, based on the midpoint rule, the exact value for normalized static polarizibility function.

$$\tilde{\Pi}(q, T) = \tilde{\Pi}^+(q, T) + \tilde{\Pi}^-(q, T)$$

$$= \frac{\mu}{E_F} + 2 \frac{T}{E_F} \ln(1 + e^{-\beta \mu}) + \frac{1}{k_F} \int_0^{q/2} \frac{dk}{1 + \exp \left( \beta (\epsilon_k - \mu) \right)} - \frac{1}{k_F} \int_0^{q/2} \frac{dk}{1 + \exp \left( \beta (\epsilon_k + \mu) \right)} + \frac{\pi}{8} \frac{q}{k_F}$$

We are interested in the region of low temperatures and small scattering vectors (colorbar rescaled):
We can look at “slices”:

My results bear close resemblance to those published in [1]:

And we see a completely different behavior from ordinary 2D polarizability (from [1])

7.4 Conductivity and Resistivity

The goal was to calculate the conductivity 
\[ \sigma = \frac{e^2 v_F^2}{2} \int_0^\infty d\epsilon D(\epsilon) \tau(\epsilon) \left( -\frac{\partial f}{\partial \epsilon} \right) \]
and reach the resistivity from 
\[ \rho = \frac{1}{\sigma} \].
Where \( D(\epsilon) = \frac{2}{\pi \hbar v_F^2} \) for graphene and \( D_{2D}(\epsilon) \) for a 2DEG are the density of states.

\(-\frac{\partial f}{\partial \epsilon}\) is the derivative of the Fermi distribution, discussed above.

The relaxation time is \( \frac{1}{\tau(\epsilon)} = \frac{2\pi \hbar}{\sum_k n_k^2} \int \frac{d^2 k}{(2\pi)^2} |\langle V_{sk.sk'}\rangle|^2 \left[ 1 - \cos \theta_{kk'} \right] \delta(\epsilon_{sk} - \epsilon_{sk'}) \)

Where \( |\langle V_{sk.sk'}\rangle|^2 = \left| \frac{\psi(q)}{\psi(q)} \right|^2 \frac{1+\cos \theta}{2} \) for graphene, and \( |\langle V_{sk.sk'}\rangle|^2 = \left| \frac{\psi(q)}{\psi(q)} \right|^2 \) for 2DEG.

\( U(q) = \frac{v(q)}{\psi(q)} \times \frac{2\pi e^2}{\hbar^2} \) for graphene, and \( U(q) = \frac{v(q)}{\psi(q)} \times \frac{2\pi e^2}{\hbar^2} \) for 2DEG.

So for graphene the expression is simplified (by replacing the angular integral over \( \theta \) with integration over \( q \)) to \( \frac{1}{\tau(\epsilon)} = \frac{2\pi \hbar}{\sum_k n_k^2} \int_0^{2\pi} \frac{d\theta}{2\pi} \sqrt{1 - \left( \frac{q}{q} \right)^2} \) \( \times \left( \frac{q}{q} + q \right) \). I calculated this expression numerically, based on the midpoint rule.

Theoretically the integral over the energy \( \epsilon \) in the conductivity \( \sigma \) is from zero to infinity. In practice, since \(-\frac{\partial f}{\partial \epsilon}\) is a narrow - delta like function, it is enough to calculate up to some maximal energy \( \epsilon_{max} \).

So we see that for relatively small temperatures, say up to \( T/T_F < 2 \), the energy range I have chosen is sufficient, because the value of \( D(\epsilon) \tau(\epsilon) \left(-\frac{\partial f}{\partial \epsilon}\right) \) approaches zero. Hereafter, the focus will be in temperatures in that range. Calculating the integral over the energy \( \epsilon \) (midpoint rule), I got the following graphs for the conductivity, and it’s inverse - the resistivity.

Often it is useful to compare the normalized sizes.
My result resembles that achieved in [1]. The interaction parameter for graphene is $r_s = e^2/k\hbar v_F$, in the result shown above it is 2.

The functional dependence of the resistivity on temperature differs immensely from that of an ordinary 2D system (from [1]).

The interaction parameter $r_s$ is the ratio of available kinetic and potential energy in the system. For a 2DEG it is $r_s = me^2/\kappa \sqrt{n}$.

References


